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Futurecom Repeater Configurator (FRC) 
Release 1.30 – Release Notes – May 2022  
 
FRC Software (6A083X06):  New Version:1.30 Old Version: 1.29 
 
Note: FRC 1.30 software supports all hardware platforms: DVR-LX®, DVR, VRX1000, 
PDR8000®. 
 
FRC 1.30 contains three main components to service all hardware programming needs  

1. Configurator for VR Repeaters (DVR-LX®, DVR, VRX1000, PDR8000®), ver. 1.30  

2. Configurator for PDR8000®, ver. 1.30 

3. Flash Downloader Utility, ver. 2.00 

 
FRC is compatible with following Futurecom Firmware Versions: 

This release of FRC is backwards compatible with all APX repeater firmware versions. It 
supports reading and writing to all previously configured devices. 
 
To access new features/enhancements/improvements listed below, the repeater must be 
using applicable firmware version as identified in compatibility chart. 
 
Firmware Compatibility Chart is located on the Futurecom Website in the Support Portal:  
Home > Support > Documentation and Software > DVR-LX/DVR/VRX1000 

 
New Features / Enhancements:  

• NAC Linking Compatibility option shown when detecting firmware version 1.73 or later.DVR-

1515 

• Eliminated incorrect warning message when loading DPD/DCDs created from a sibling 

DVR/DVR-LX, allowing user to move easily between DVR and DVR-LX units DVR-1398 

Issues Fixed 

• FRC now warns user of mismatched licensing options DVR-1053, DVR-1298 

• PDR - Error shown when loading previously saved DPD file PDR-686  

• Offline editing DCD file does not allow creation of new Repeater Channel 
(issue since FRC 1.27) DVR-1372 

 

Field Names Updates 

• FRC “Save DCD File” menu option changed from Attach to Bundle DVR-1489  

• Removed “Use MSU Emergency ID” on FRC Emergency Setup Window DVR-1460 

• "Morse Code" Sub-folder is called "Station ID Setup" in the window FRC DVR-1389 



  FRC 
  Release 1.30 
  Release Notes 

May 9, 2022  Page 2 of 10 

• AVRA, Primary/Secondary Preference input name replaces AVRA/Primary/Secondary 

Preference DVR-1399 

Known Issues 

• N/A 
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HISTORICAL RELEASE NOTES FOR REFERENCE 
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Release 1.29 – Release Notes – December 2021  
 
FRC Software (6A083X06):  New Version:1.29 Old Version: 1.28 
 
Note: FRC 1.29 software supports all hardware platforms: DVR-LX®, DVR, VRX1000, 
PDR8000®. 
 
FRC 1.29 contains three main components to service all hardware programming needs  

4. Configurator for VR Repeaters (DVR-LX®, DVR, VRX1000, PDR8000®), ver. 1.29  

5. Configurator for PDR8000®, ver. 1.29 

6. Flash Downloader Utility, ver. 2.00 

 
FRC is compatible with following Futurecom Firmware Versions: 

This release of FRC is backwards compatible with all APX repeater firmware versions. It 
supports reading and writing to all previously configured devices. 
 
To access new features/enhancements/improvements listed below, the repeater must be 
using applicable firmware version as identified in compatibility chart. 
 
Firmware Compatibility Chart is located on the Futurecom Website in the Support Portal:  
Home > Support > Documentation and Software > DVR-LX/DVR/VRX1000 

 
New Features / Enhancements:  

• The configuration field to support Primary/Secondary Preference feature is added to the 

Hardware setup window, also viewable under the Primary/Secondary Setup window. DVR-

1208 

• Monitoring Setup window: new field added for AVRA/Motion Input. DVR-1326 

• New Business Rules: 

o VR Common Setup window: When Rptr Independent Channel Change is unchecked 

and VR Activation vis MSU Mode Change is checked, then all Power UP Options 

fields are grayed out. DVR-971 

o Repeater Channel Setup window:  UID TRNSL can only be set to Yes when 

Channel Type is Digital. DVR-415 

o VR AVRA Polarity is only editable if AVRA Uses VIP on CH is unchecked. DVR-1242 

o Hardware Setup window: if GPS Driven Deactivation is enabled, a Speed Threshold 

and/or Distance Threshold must be configured. DVR-1215 
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Issues Fixed 

• If DPD file read immediately after starting FRC, Repeater Channel Setup window is 

opened. DVR-1228 

• Default value for Rx and Tx NAC correctly set to 293 DVR-1308 

• Offline DCD to DPD file creation will result in error DVR-1051 

Field Names Updates 

• VR Common Setup window: “Enable Bypass Algorithm for APX 8500” changed to 

“MSU RF Bypass Switch Extension (APX 8500 and All Band Antenna)” DVR-1292 

• VR Common Setup window: “Fallback to Local Repeat Disabled” changed to 

“Block Fallback to Local Repeat” DVR-272 

• Emergency Setup window: “Disable VR Emergency Call State” changed to “Block 
Emergency Call State” DVR-272 

• Digital System Setup window: “PSU Proxy Disabled” changed to “Block TG Proxy” DVR-272 

• Navigation Tree: “Maintenance (F5)” has been changed to “Maintenance” DVR-1288 

Known Issues 

• Offline editing DCD file does not allow to create new Repeater Channel DVR-1372 

• When loading a template file after data was loaded from repeater, Feature Licenses listed into 

the User Info screen will show the licenses status in the template instead of what’s in the 

repeater. This may allow user to configure fields that require feature license. This allows 

configuration of licensed feature fields that will not apply to a VR unless the feature license 

has been applied first.DVR-1298 

• Creating a DCD file from a DPD file offline is not recommended at this time.  Please refer to 

the instructions in the VR Programming Guide for how to create a DCD file. 

• GPS Driven Deactivation Feature: Hardware Setup window -> Speed and Distance thresholds 

set with km/h and metres are saved incorrectly.  Use mph and feet for speed and distance 

thresholds. DVR-1443 

 



  FRC 
  Release 1.30 
  Release Notes 

May 9, 2022  Page 6 of 10 

FRC Release 1.28 –September 1, 2021 
 
Compatible with following VR Firmware Versions: 1.71 or earlier 

 
New Features / Enhancements in Release 1.28:  

• Allow feature licenses to be applied to a template file (DCD/DPD) offline. DVR-853 

• Added ability to “Inspect DCD file”: provides visibility to serial number and feature license 

information. DVR-857 

Issues Fixed in Release 1.28 

• Downgrade from Tier3 to Tier1 does not use autocorrection for digital channel types. When 
a template is applied to a Tier1 VRX1000 with unsupported channel types, FRC 
automatically changes the channel type to Analog but user is then prevented from saving 
the file. FRC now leaves the channel type as per the template file but highlights the field in 

red for user correction. Saving of the file is then allowed. DVR-508 

• Monitoring Window→PL field displays empty green box for FW 1.63 and older. DVR-1027 

Field Name Updates in Release 1.28 

• Changed File→"Apply License File to Repeater" to "Apply License File". DVR-853 

Known Issues in Release 1.28 
• Minimize button on configuration windows does not work after maximizing window size.  

Workaround: Restore Down button may be used instead. DVR-896 

• When MSU is set to a display language other than English, MSU Data→Radio Display 
Language is incorrectly flagged as an error. Workaround: Set MSU display language to 
English. DVR-904 

• When a single negative number is entered (e.g. -7) into either VR Remote Activation IDs or 

PSU IDs Allowed table, it will automatically be treated as range 0 to 7. DVR-1055 

• Offline DCD to DPD file creation will result in error. DVR-1051 

 
Field Name Updates in Release 1.28 

• Changed File→"Apply License File to Repeater" to "Apply License File". DVR-853 
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FRC Release 1.27 – Release Notes July 2021 
 
Compatible with following VR Firmware Versions: 1.70 or earlier 

 

New Features / Enhancements in Release 1.27:  
• GPS Driven Deactivation—new licensed feature that requires new firmware and GPS 

enabled radio. 

• NAC Linking feature 

• Allow saving DCD files with errors to save progress for future editing. DVR-851 

• Added capability to create a backup EPR file for Futurecom Support during firmware 

upgrade/downgrade. DVR-701/702 

• Added default filename (based on serial number) for DCD files when saving. DVR-873 

• When Hardware Setup➔AVRA➔Automatic VR Activation is disabled (unchecked), all 

other AVRA fields are greyed out. DVR-739 

• Added license file to command line (use -d1 -u<filename>) DVR-374 

• Added file history for DCD files for easier access to recently used files DVR-872 

Issues Fixed in Release 1.27 

• EEPROM Maintenance icon flashing yellow incorrectly identifying configuration changes to 

be saved after loading DPD/DCD file. DVR-484 

• Configuration changes to Mobile Radio Channel Setup→VR Ch. List for MSU 

Zone/Channel entry 1364 and over not saved.DVR-263 

• Unintentionally changing the configured values for PSU Scan in the Repeater Channel 

Setup window when loading a DPD template file. DVR-832 

• Fixed DPD loading not applying user license options. DVR-837 

• Added warning message upon loading of DPD files saved with older versions of 
FRC/Tweaker: "Warning—VR Activation via MSU Mode Change field value may not have 
been retained. Please go to the VR Common Setup window and verify the value set will 

provide expected operation."  DVR-878 

Field Name Updates in Release 1.27 

• Main Menu: File menu entries updated.DVR-852 

o “Load Rescue File” updated to “Apply Rescue File to Repeater” 
o “Load License File” updated to “Apply License File to Repeater” 
o DPD Files ➔ “Apply DPD to APX Repeater” updated to DPD Files ➔  “Apply DPD 

to Repeater” 
o DCD Files ➔ “Apply DCD to APX Repeater” updated to DCD Files ➔  “Apply DCD 

to Repeater” 

• VR Common Setup window: “No Activity Timer" updated to "Inactivity Timer" DVR-836 

• Reorganize controls for saving DCD with license DVR-855 
o removed File ➔ DCD Files ➔ “Save DCD File with License”  
o updated File ➔ DCD Files ➔ “Save DCD File” dialog box with license selection 

option 
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Known Issues in Release 1.27 
• Minimize button on configuration windows does not work after maximizing window size.  

Workaround: Restore Down button may be used instead. DVR-896 

• When MSU is set to a display language other than English, MSU Data→Radio Display 
Language is incorrectly flagged as an error. Workaround: Set MSU display language to 
English. DVR-904 

• When a single negative number is entered (e.g. -7) into either VR Remote Activation IDs or 

PSU IDs Allowed table, it will automatically be treated as range 0 to 7. DVR-1055 

• Offline DCD to DPD file creation will result in error. DVR-1051 
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FRC Release 1.24 –February 11, 2021 

 
Compatible with following VR Firmware Versions: 1.64 or earlier 

 
New Features / Enhancements:   
• Improve clarity of error messages when loading license file that has already been applied. 

DVR-513 

• Aligned Feature License name with our official names in Ordering Guide. DVR-545 

• Added warnings when reading/writing live data, DPD or DCD files if FM deviation values 

are low. DVR-552 

• Changed "EPR Files" in menu to "EPR Files (Futurecom Support)”. DVR-550 

• Added Copy Data feature for Repeater Channel screen. 

• Renamed "Legacy PSU Compatibility Mode Enabled" to "Legacy PSU Compatibility Mode" 

• DCD file can be upgraded with license option file. 

• Renamed OTAP Setup screen to Update Info and display the screen at all times 

 
Issues Fixed in This Release 
• Fixed issue where single band FM deviation value was incorrectly halved when loading old 

DPD files.  DVR-552 

• Fixed Talkgroup ID out of range error message being off by 1 for the start of the range. 

• Fixed loaded DCDs displaying incorrect serial numbers when re-saving. 

• RSSI for monitoring window may not be displayed properly – fixed.  

• Fixed VR Common setup window causing invisible error. DVR-537 

 
Reminder  
Creation or modification of DCD should be done after a repeater is read.  

  

http://10.18.1.101:8080/browse/DVR-482
http://10.18.1.101:8080/browse/DVR-482
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FRC Release 1.22 – November 24, 2020 
 
Compatible with following VR Firmware Versions: 1.63 or earlier 

 
New Features / Enhancements:   
• Added info in popup when user attempts to add entry to maxed out table screen (PSU IDs, VR 

Activation IDs, TG Translation table, and channel screens) (DVR-261) 

 
Issues Fixed in This Release 
• Power Up Mode programming not transferred properly via DCD file  (DVR-482) 

• Invalid DCD / DPD created if USB cable switched and VR Info requested (DVR-488) 

• Fixed Steering ID searching for duplicate IDs in zones, causing unnecessary errors to 
appear (DVR-503) 

• Fixed MSU sync hash not updating when saving a DCD from a loaded DCD (DVR-509) 

 
Reminder  
Creation or modification of DCD should be done after a repeater is read. Create a new DCD 
template or apply old one and make the necessary modification.  

 

http://10.18.1.101:8080/browse/DVR-261
http://10.18.1.101:8080/browse/DVR-482
http://10.18.1.101:8080/browse/DVR-488
http://10.18.1.101:8080/browse/DVR-503
http://10.18.1.101:8080/browse/DVR-509

