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Document Revisions

Rev Date Notes & References
1.0 2018-07-31 Instructions for Release 2.0 to 3.0 upgrade.
2.0 2019-11-21 Instructions for Release 3.0 to 4.0 upgrade.
3.0 2021-11-15 Instructions for Release 4.0 to 5.0 upgrade.
5.0 2022-08-04 Updated formatting and clarified instructions
5.1 2022-12-07 Updated logo
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Introduction

The PDR8000 Software Release 5.x supports all PDR8000 hardware up to Revision 5.0.
This document describes how to upgrade the PDR8000 firmware from Release 4.0X to
Release 5.x. For upgrading from older versions than 4.00 of PDR8000, please contact
customer support

NOTE: All programs mentioned in this document must be executed from a local
storage on the PC attached to the PDR8000 via USB cable.

DO NOT run programs from network storage or drives.

Preparation

The PDR software suite contains two main components.
o Firmware (Embedded Software running on PDR8000)

e Futurecom Repeater Configurator (Programming application to configure the
PDR8000, further referred to as FRC)

Before upgrading the PDR8000 firmware, existing data files must be saved using the
following steps.

1. Power up the PDR8000
2. Connect the PC to PDR8000 Rev 4.0 using the USB interface cable

3. Open FRC (Recommend using latest version of FRC available at Futurecom
website — Support — Documentation and Software — PDR8000)

4. In the bottom right corner of the FRC launch window, click the ‘PDR8000® button
on the Configurator tab.

Futurecom Repeater Configurator X

Configurator ]Tools

ssssssssssssssss

Futurecom Repeater Conflgurator

POLICE

Select which device you would like to configure:

‘ ‘ . FRC R1.30

R1.30-0035
DVR-LX® / DVR / VRX1000 1 © 2022 Futurecom Systems Group, ULC PDR8000® ‘

Figure 1 - FRC Launch Screen for PDR8000® Selection
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5. Press F2 or select from menu PDR->Load Data from PDR8000

Futurecom Repeater Configurator 1.26e (PDR8000) (Default) -

FileAppIicaiion User Options Help

Save Changes To PDR8000
Reset PDR8000 F3
EEprom Maintenance Ctrl+E

Set Device Date and Time

Configure Deployments

| (Port: COM-5 (115200 b/s))

Figure 2 - Load Data from PDR8000
6. Make sure there are no errors in the configuration

7. Save DPD file by selecting from the menu File->DPD Files (Templates)->Save
DPD file. Remember the folder location and hame when saving the DPD file.

a Futurecom Repeater Configurator 1.26e (PDR8000) (Default) - 20010015 - — O X
File. PDR Application User Options Help

Apply DPD To PDR8000

Load Rescue File Load DPD File Ctrl+F6
Load License File Create New DPD

Preferences

Exit

: Hardware/Software Infi
i Common Settings

1 - Deploymentl [STARTU
- Deployment2

- Deployment3

- Deployment4

- Deployment5

- Deployment6

- Deployment7

- Deployment8

- Deployment9

--88 10 - Deployment10

- Service

ppEppEpEPEREER
CENOUAWN

[Repeater (Port: COM-5 (115200 b/s)) o \ 4

Figure 3 - FRC Save DPD File

2022-12- Page 4 of 12



8M088X01 R5.
PDR8000® Portable Digital Repeater Firmware Upgrade Instructions

8. Save EPR file by selecting from menu File>EPR Files (Futurecom Support)
->Save EPR File **, Remember the folder location and name of the EPR file
when saving.

9 Futurecom Repeater Configurator 1.26e (PDR8000) (Default) - 20010015 - — Od X
File PDR Application User Options Help
DPD Files (Templates) >

Load Rescue File Load EPR File F6

Load License File
Preferences

Exit

i Hardware/Software Infi
i Common Settings
- Deploymentl [STARTU
- Deployment2
- Deployment3
- Deployment4
- Deployment5
- Deployment6
- Deployment7
- Deployment8
- Deployment9
- 10 - Deployment10
@ Service
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[Repeater (Port: COM-5 (115200 b/s)) | Y

Figure 4 - FRC Save EPR File

NOTES:
** |t is very important that EPR file be saved before upgrading firmware.
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Upgrade Firmware to Release 5.x

Once the preparation is complete, the PDR8000 firmware can be upgraded with the
following steps.

1. Close FRC application if it is running on the PC
2. Create a ‘Firmware Upgrade’ folder on the PC

3. Download the PDR8000 Firmware R5.x file from Futurecom website — Support
— Documentation and Software — PDR8000

4. Unzip the downloaded file and save the files in the folder created in step 1.

5. If PDR8000 is not powered up and connected to PC, power up and connect
PDRB8000 to an available USB port on the PC

6. Run FRC from the shortcut icon created on the desktop or by searching for it in
the Windows search bar.

7. In the top left corner of the FRC launch screen select the ‘Tools’ tab and then

launch the Flash Downloader Utiliti bi iressini the ‘Flash Downloader’ button.
Futurecom Repeater Configurator X

Futurecom Repeater Configurator

TOOLS

POLICE

Select which tool you would like to use:

Flash Downloader

Figure 5 - Flash Downloader Utility FRC Launch Screen

8. Ensure no other program is trying to use the same USB port.

9. From the Flash Downloader Utility window menu select File>Open and specify
the location of the PDRFirmware.cfg file in the ‘Firmware Upgrade’ folder.
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m Flash Downloader Utility 6D900X03 - 2.00 — O X
1. Click Here File Help
Open Ctrl+O ~
2. Click Here pef OME USB v[
Exit
Scan Ports | Crnd: I
Application Messages Response From Radio

© 2020 Futurecom Systems Group, ULC

Data Transferred: | 00%
Figure 6 - Flash Downloader Open Firmware File

Flash Downloader Utility 6D900X03 - 2.00 - |

File Help

Download Port:  |COM5 USB >

Scan Ports Cmd |
Open X
Application Messages
i « DVR.. » PDR8000 Firm... v | D £ Search PDR8000 Firmware R...
Organize ~ New folder = - 0
® 2020 Futurecom Systems Group, ULC -
& This PC & Name Date modified
_J 3D Objects | | PDRFirmware.cfg 2019-10-30 7:54 AM
[ Desktop
5 Documents
¥ Downloads
D Music
& Pictures
i Videos
. Windows (C)
= FC1 () v < >
Data Transferred: |
File name: |PDRFirmware.cfg v ‘ Config Files (*.cfg) v

Figure 7 - Flash Downloader Select Firmware File
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10. Click on the ‘Download’ button to start the downloading process.

(@Y Flash Downloader Utility 6D900X03 - 2.00 — O x
File Help
- i A
Download Port:  [COME USB hd
Scan Paorts Crnd |F\a5hDownIoader -b1156200 -c300 -psn_t<t.upf -e14C088X01_601_4
Application Messages Response From Radio
2020 Futurecom Systems Group, ULC
USB modern on port COMS
Data Transferred 0.0%4 v

Figure 8 - Download Firmware to PDR8000

11. Observe the Application messages and progress. Wait until the download is
completed 100% successfully.

(@Y Flash Downloader Utility 6D900X03 - 2.00 — O XK
File Help

Port:  |COMB USB hd

Scan Ports Cmd ‘F\ashDownloader -b116200 -c300 -psn_xdt.upf -2 14C08BEX01_601_4

Application Messages Response From Radio

Enable Write A +11 02
Select Flash page 119+19 89 227E
Erasing IFB Application Flash page - this may take a while N6+1607
" PLEASE WAIT ™ 13+1307
Send Application file {binary fransfer) 11441407
Reading 4C088X07_121_400.upf +15 F9 00000000
Transfer file N9+19 89 227E
523916 bytes sentin 64.4 sec NG+168 F
Transfer rate: 8.1 KBy/sec N3+138F
Switch to ASCII N4+148F
Switch remote to ASCII +15 F9 00000000
It Download completed successfully +11.01
Resetting remoate ... 00+00 01
Restore Bridge NC+30 0008
Bye 03
Resetting PDR . +2F 0 EE
Download Completed Successfully +03

v v

bata Transferred: [ HNNNENNNENNRNNNENENNNNNNNNNR  1000%

Figure 9 - Firmware Update Progress
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12. After the Download Completed Successfully message appears, close the Flash
Downloader application.

Apply the DPD File

This is the last set of steps after firmware has been upgraded to Release 5.x.

1. Download the latest FRC Release from Futurecom website — Support —
Documentation and Software — PDR8000

2. Install and run FRC downloaded in step 1.

3. In the bottom right corner of the FRC launch window, click the ‘PDR8000® button
on the Configurator tab (see Figure 1).

4. From the FRC window that appears, select File>DPD Files (Templates)->Apply
DPD to PDR8000.

a Futurecom Repeater Configurator 1.26e (PDR8000) (Default) - — O X

File PDR Application User Options Help

EPR Files (Futurecom Support) > Save DPD File

Load Rescue File Load DPD File Ctrl+F6
Load License File Create New DPD
Preferences

Exit

| (Port: COM-5 (115200 b/s))

Figure 10 - FRC Apply DPD to The Repeater

5. Click ‘OK’ on any Errors/Warning messages that appear

6. On the ‘Open File’ dialogue, select the DPD file saved in step 6 of the
Preparation chapter.
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& Futurecom Repeater Canfigurator 1.262 (PDRB00D) (Default) - 20010015
File PDR Application User Options Help

Figure 11 - Select R4.0x DPD file
7. Click Yes/Continue on any of the confirmation windows that appear.

&3 Open File
Lookin: | | DPDFia v] smo@r
Name Date modified
Select R4.0x file [0 poRdpd 20210414 9:25 Al
Hardware/Software Inforn|
- Common Settings
LS - Deployment1 [STARTUP (
B - Deployment 2
"
"
®
®
®
& N
& Deploymentd :
10 - Deployment10 “
= Service
~ Monitoring < 5

Status Report

Status Log File name: [Ra0_POR dpa =] Open

Status EEPROM Log

Files of type: [DPD file * dpd) ~| Cancel
[ Open as read-only
[ Preview File Header
< > ‘ A

8. The Pop-up window appears. Select the screens which are to be loaded from the

list (typically all windows) and click ‘OK’.

a Futurecom Repeater Configurator 1.26e (PDR8000) (Default) - 20010015 -
File PDR Application User Options Help

PDR

Select screens to load from DPD...

L35 e B S L T

=@ PDR Only selected screens will be updated ! Cancel oK
@ COM Options
Ports Screens : [
@ PDR Configuration [V Personality Information
Frequency Band Configurat [V Frequency Band Configuration
i Personality Information [V Common Settings
- Hardware/Software Inform [V Channel Configuration: 1 - Local Disp - Gen
Common Settings = B
® 1 - Deployment1 [STARTUP ( iGeneraI Configuration: 1 - Local Disp - Gen
™ 2 - Deployment2 i Channel Ci ion: 2 - Depl 2
@ 3 - Deployment3 v G 1 C i 2- I 2
& 4 - Deployment4 [V Channel G ion: 3 - Depl 3
@ 5 - Deployment5 v G 1 C i 3 I 3
& 6 - Deployment6 [V Channel C ion: 4 - Depl
@ 7 - Deployment7 7 G 1C N 4.
- 8 - Deployment8 v .
.81 9 - Deployment9 _Channel C ion: 5 - Dy 5
@ 10 - Deployment10 i" I C i 3-
@ Service ¥ Channel C ion: 6 - Depl 6
! Monitoring VG 1C i 6- I
i~ Status Report [¥ Channel C ion: 7 - Depl 7
- Status Log [V General C ion: 7 - Depl 7
Status EEPROM Log v Channel C ion: 8 - Depl a
e 1 C ion: 8 - Depl,
[V Channel C ion: 9 - Depl
v 6 1 C ion: 9 - 9
[V Channel G ion: 10 - D 10
v G 1C ion: 10 - 10

|[Repeater (Port: COM-5 (115200 b/s))

Figure 12 - PDR Screen Selection
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9. When the process finishes, if there are any error indications on the main FRC
menu, correct the Errors manually by clicking on the field.

10. If errors needed to be corrected, then once done, press F4 or select from menu
PDR->Save Changes to PDR8000 to complete the upgrade.

B Futurecom Repeater Configurator 1.26e (PDR800D) (Default) - 20010015 - — [m] X
File PDR Application User Options Help
Load Data From PDR8000

Reset PDR8000

EEprom Maintenance

Set Device Date and Time
Configure Deployments

-~ Hardware/Software Infi
- Common Settings

- Base [STARTUP]

- Analog

- Repeater (KD)

- Satellite Rx

- Satellite Tx

Figure 13 - FRC Save Changes to PDR8000

11. Save DPD file by selecting from the menu File>DPD Files (Templates)->Save
DPD file. Give this file a different name to differentiate it from the file saved
before the update. Remember the folder location and name when saving the
DPD file.

E Futurecom Repeater Configurator 1.26e (PDR8000) (Default) - 20010015 - — Od X

File PDR Application User Options Help

Apply DPD To PDR8000

Load Rescue File Load DPD File Ctrl+F6
Load License File Create New DPD

Preferences

Exit

Hardware/Software Infi
Common Settings

- Deployment1 [STARTU
- Deployment2

- Deployment3

- Deployment4

- Deployment5

- Deployment6

- Deployment7

- Deployment8

- Deployment9

@ 10 - Deployment10

@ Service

2 g8

&

B-E-E
prrEpRrEREER

&
LN A WN -

o--&

[Repeater (Port: COM-5 (115200 by/s)) [ [ 4

Figure 14 - FRC Save DPD File
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12. Save EPR file by selecting from menu File>EPR Files (Futurecom Support)

->Save EPR File **. Give this file a different name to differentiate it from the file

saved before the update. Remember the folder location and name of the EPR file
when saving.

E Futurecom Repeater Configurator 1.26e (PDR8000) (Default) - 20010015 -

File PDR Application User Options Help

DPD Files (Templates) >

Load Rescue File Load EPR File F6
Load License File
Preferences

Exit

Hardware/Software Infi
--- Common Settings
-~ 1 - Deployment1 [STARTU
2 - Deployment2
3 - Deployment3
4 - Deployment4
-~ 5 - Deployment5
-~ 6 - Deployment6
7 - Deployment7
8 - Deployment8
@ 9 - Deployment9
@ 10 - Deployment10
- Service

v
S

|Repeater (Port: COM-5 (115200 b/s))

Figure 15 - FRC Save EPR File

NOTE: ** It is very important that EPR file be saved after upgrading firmware.
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